Contentbox headline

Welcome, Guest. - LoginView Forum

NoxiousOT 8.60 >> Bug Report >> (inquisition quest bug)
October 13, 2018, 1:56 pm
Join Date: Sep. 2018
Profession: Knight
Level: 8
Posts: 11
(inquisition quest bug)


i tried to start the inquisition quest series and i took the second quest and i am supposed to go to NPC Uzon and say eclipse so i can get teleported to quest area but i tried to talk to npc and said eclipse but i got no response. so the following were my tries:

1) Tried to talk to Henricus NPC in case i missed anything but he doesn't reply to mission so this part is done
2)i tried writing eclipse in many formats but still got no response (e.g. Eclipse, ECLIPSE, eclipse. etc...)
3) waited 24 hours before trying to talk to NPc (maybe it was bugged and after server save it was fixed) but still i got nothing

can you please check it out ? i cant finish this quest without the NPC teleporting me

PS: when i received this quest henricus he should have spoken 3 messages after the first one , i left him ( since i already got the flask of holy water) but could this action bugged the quest ?

Last edited by Arcanius Knight; 13th Oct 2018 at 17:23:26.

October 13, 2018, 9:46 pm
Join Date: Nov. 2017
Profession: Druid
Level: 8
Posts: 24

You dont need to do any of those parts to do inquisition. Just go to the actual quest and kill all the demons.

Monster of the Week Monster Pedestal and Players Online Box
Players Online
Giveaways and more..
100 members online